Dropbear Latest on IRIX 6.5.30 - Problems

Matt Johnston matt at ucc.asn.au
Tue Aug 7 21:19:11 AWST 2018


On Mon, Aug 06, 2018 at 09:33:31PM -0400, Kazuo Kuroi wrote:
> Greetings, I'm working with a friend of mine to port modern software to IRIX 6.5.30, and since OpenSSH is... very difficult to compile on IRIX at this point, we're hoping to use Dropbear as a good alternative. Unfortunately, we're not getting farther than the configure stage: Here's the config.log from GCC 4.7.3: https://pastebin.com/ZDftG1xa We also have tried the native cc and they choke here: gmake -j4
> Creating default_options_guard.h
> Unknown flag: E
> gmake: *** [default_options_guard.h] Error 2 Unfortunately we're not familiar with the build system for Dropbear, so maybe we're doing something wrong? I've tried searching the mailing lists for info on IRIX compliation but I've not seen anything super recent. Best Regards, Kazuo K.

Hi Kazuo,

It should be fixed this recent change
https://github.com/mkj/dropbear/commit/195934be96aa2aabd0bec0adf14f242155008e50

It was assuming GNU sed.

Cheers,
Matt


More information about the Dropbear mailing list