Cannot get fish protocol to work with minimal system [SOLVED]

Rui Santos rsantos at
Mon Jul 9 22:41:35 WST 2007

Rui Santos wrote:
> Hy,
>     I'm trying to get dropbear to wotk on a minimal system. Everything
> is working except the Konqueror fish:// protocol. I can ssh to dropbear,
> make keys with dropbearkey and I'm able to scp to and from that machine...
>     I also installed it on my PC, a openSUSE10.2 full system, started it
> and it all works... It just doesn't work on the minimal system machine
> that I'm trying to set up... I believe something is missing from my
> setup but, I was unable to find out what it is... Can anyone give a few
> hints on what could be missing ?

    I found out why... The ls from busybox didn't had the -L option
compiled within it. I turned all ls options on and it worked like a charm.

    Just an advice for anyone having problems with dropbear. Use strace
( with the -f  option) - It really helps.

> Thanks in advance,
> Rui Santos



*Rui Santos*
Dep. Testes

*GrupoPIE Portugal, S.A.*
Tel:   +351 252 290 600
Fax:  +351 252 290 601

Email: rsantos at <mailto:rsantos at>
Web: <>


More information about the Dropbear mailing list